ECE574 Jim Duckworth

Encoder (VHDL and Verilog) — Xilinx Implementation and Simulation
(updated by Kahraman Akdemir, September 2006)

Start Project Navigator. Select File => New Project
Enter name and location, select device.
Select New Source. Select VHDL Module and provide name:

E New Source Wizard - Select Source Type M= E

’:I IP [Coregen & Architecture \Wwizard]
] Schematic

v | Werilog Module File name:

Iencoder
WHOL Library Logation:
| VHDL Package Il::'\Dncuments and Settingz\K.ahramanhDesktophen . |

] WHOL Test Bench
W) Embedded Processor

[v &dd to project

More Infa | < Back | Mewut » I Cancel

Click Next.

Enter required inputs and Outputs:

E New Source Wizard - Define Module M =

Entity Mame Iencoder

Architecture Name IBehavio[aI

FPort Mame Direction Busg M5B LSB | |
i in =
il in =
i2 in =i
i3 in d -
a ot = i 1 1]
in d r
in = —
in hd - -
in d -
in d - ;I

More Info | < Back | Mext » I Cancel |

Click Next, etc.
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A skeleton of your VHDL file is created:

[encoder.vhd]

IREL-TIEY

2 H@E’tﬁtﬁtﬁﬂf@[mﬂux%r@ Y G =1

IEEE=1 =N (4% 0 %@ .S & [0 =lw =
I=| 1 [library IEEE; =]
Sources for. | Synthesis/Implementation | 2 use IEEE.STD LOGIC 1164.ALL:
i use IEEE.STD LOGIC ARITH. ALL;
-~ Elencoder 4 use IEEE.STD_LOGIC UNSIGHED.ALL:
2 £ 200416256 . = =
[l encoder - Behaviors (sncoder vhd) 6 -——— Uncomment the following likrary declaration if instantiating
7 --—— any Xilinx primitives in this code.
8 ——library UNISIH;
=) —-use UNISIN.VComponents.all;
10
11 entity encoder is
1z Port ( i0 : in STD_LOGIC:
e il : in STD_LOGIC;
14 iz : in STD_LOGIC;
15 i3 : in STD_LOGIC;
16 & : out STD LOGIC VECTOR (1 downto O));
17 end encoder;
1§ Sowces | g Snapshots | [ Libraries | o
x| 19 architecture Behavioral of encoder is
20
Processes: 1= 21 hegin
i Add Existing Source 22
Create New Saurce 23
View Design Summany b 24  end Behavioral:
Deesign Utiies B85
SF  User Constraints _IJ 8
4] | _'LI
4 0000 | 3
2f Processes
encoder I
z [
Started : "Launching Design Summary”.

4 | _"—I
Consols | @) Enors |\, Wamings | igg Findin Files

[Ln 1 ol [Cars [WOmM [SCRL [WHDL
Enter the architecture statements.
Double-click on the Synthesize-XST in the process window.

Note the warning message (this is valid)

[FEL-IEY:]
[EERl=1EP=r

& [I@Efafafaﬂli@h&k’\ﬂx%ﬂé S =
2[4 0@ . b= E [0 lw =]

x 1 library IEEE; -
Sources for. | Synthesis/Implementation | B o= [EEE: STDFLOGIC, L1Ed-ALL:
3 use IEEE.STD_LOGIC_ARTTH.ALL:
~ ®encoder 4  use IEEE.STD_LOGIC_UNSIGNED.ALL:
£75 1c3s200-44256 5
E nﬁer\cndar Behavioral [sncoder.vhd] f Tncoument the following library declaration if instantiating
7 any Xilinx primitives in this code.
& --lihrary UNISIM;
El --use UNISIM.VComponents.all;
1in
11  entity encoder is
13 Sowces | g Snapshots | [ Libraries | 12 Fort ( 40 : in STD_LOGIC;
13 il : in STD_LOGIC:
x| 14 iz : in 5TD_LOGIC:
15 i3 : in STD_LOGIC:
Processes: - 16 a : out §TD_LOGIC VECTOR {1 dewnto D))
% Desion Utiities 17 end encoder;
5 User Constraints e ;
& 19 architecture Behavioral of encoder is
20
2] @WView Syrthesis Report 21 begin
~[@  View RTL Schematic 2z
~[]  View Technology Schematic 23 a €= "L17 uhen 13 = ‘10 else
t; Check Syntax 24 10" when iZ = '1' else
G PostSynth Siraul Model 25 "01" when il = 'l' else
) Generate PostSynthesis Simulation Model 26 naoe; |
Implement Design - 27
Generate Pragramming File 26 end Behawioral;
T | - |
4 0000 | 3
2f Processes
encoder I

X  Synthesizing Unit <encoder>.
Related source file is "C:/Documents and Sectings/Kahraman/Desktop/encoder/encoder.vhd".
1, UARNING:¥st:647 - Input <i0> is never used.
Unit <encoder> synthesized.

|

a

2hl |

Consols | @) Enors |\, Wamings | igg Findin Files

Ready [tre col 30 [Caps i [ SCRL [WHDL
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Double-click View RTL schematic:

\Documents and Settings'Kahraman'Desktop'encoder'encoder.ise - [encader.ngr]

B Ele Edt View Project Source Process Window Help =18l x
IR IR T PP =R Y = =
EERERNEEIEY S =R IR
k|
[=-encoder
a<b_imp
al>_imp
i0 a(‘] 0) —
i1
513 Sources | gy Snapshots | [ Libraries | I Desion
EI .
No flow available. —i2
i3
P | o] B et |
= Design Objects of Properties
Top Level Symbol No obiect is selected
Instances Pins || Signals Name Value
Console | @) Erors | _#\ Wamings | g FindinFiles | EES) View by Category | 555 View by ame
I [432,172]

Double-click on the symbol to go down a level:

Documents and Settings'Kahraman'Desktopiencoder'encader.ise - [encoder.ngr]

[ Ele Edt View Project Source Process Window Help ==l
IEE PR PP =R Y I ER =
[eEoO ¢k =ssrsf EE[ang[ 2o X xm
E|
S-encader
a<0x_imp.
a<1>_imp
i am) < ETH}
[z B
@& =
g Sources | gy Snapshots | [P Libraries | W2 Desion
E|
No flow available.
e atny <]
5]
B
P | o] [ scae |
= Design Objects of Properties
encoder Mo object is selected
Instances || Pins [~ signals || Name Value
F-alLimp Fi L0
a(1Limp il =l i
2 = i2 =
Console | ©) Enors | ¢\ Wamings | g Find in Files | B View by Cateaory | 5 View by Name

[860,56]
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[ES xilinx - ISE - C:\Documents and Settings'Kahraman',Desktopiencoderiencoder.ise - [encoder.ngr]
[ Fle Edit Wiew Project Source Process Window Help =1=1x
RIS R SRR AR ] L08R E[w o]k =
=8 mnm_l.gmmuﬂﬁmaa@ PR HEM
=
= encodsr
b aels_imp
&<1>_imp
53 Souces | g Snapshots | [Py Libreries | W2 Design |
=
No flow available.
P
St P | e
1| Design Objects of Properties
a<1>_imp No obiect is selected
Instances || Fins || Signals || Name Value
-all) all] ~a[1]
a2 2 B
~all)3 i a2 E
Console | @) Erors | o\ Wamings | igg FindinFiles | B View by Category | 5 View by Mame
[ [rz2092,-172]

[@ Fle Edt Wew Project Source Process window Help 8%
IDPASLB[FR @[#E:E:E:E:F@lmv\ux I Y EE =
Iz ook [ 2EAAER ama[op
x
[ encoder
- a<z_imp
e gels_imp
=g Sowces | gy Shapshots | [ Libraries | B3 Desion I ’—D'Q_'FMD_'?—@
=
No flow available.
=4 Processes I
[fg sncodsr B encoder I
=] Design Objects of Properties
a<0>_imp Mo object is selected
Instarces [2]] Fins [~ 1] signats | [ Mame Value
-al0)1 J al) -~ ]
a2 il | =-aln
a3 =l 2 | eme |
J 5] Corsole I ) Errors I 1 Warnings I (g Find in Files J Ef| View by Categon | 55 View by Name
[ [[2548,-312]

Go back to the process window
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Functional Simulation using automatically created VHDL test bench file.
Select Project => New source
Select Test Bench Waveform and provide a file name

IS[E B3

E MNew Source Wizard - Select Source Type

BIM File
’U |P [Coregen & Architecture \Wizard)

File name:

Iencoder_waveforn'l
Location:

IE:‘\Document$ ahd Settings\K.ahramaniDesktophen . |

ﬂ WHOL Package
s WHOL Test Bench
| Embedded Processor

W Add to project

< Back | Mext > I

LCancel

More Info |

Click on Next, etc until you see the Initialize Timing window:

E Initial Timing and Clock Wizard - Initialize Timing

Check
Outputs

Wait To
= Check

Assign
Inputs

Wait To
Assign

Assign
Inputs

-p

—Clack [nfarmation

" Single Clock i0 e

—Clack Timing |nformation

Inputs are assigned at "nput Setup Time'" and

outputs are checked at "Dutput Yalid Delay!. i
& FRising Edge O g Ede " Multiple Clacks

¢ DualEdge [DOF or DET) {+ Combinatorial [or internal clock)

Clack High Time I‘I i} ns

—Combinatorial Timing Information

Clock Low Time I'IDD— ns
Input Setup Time I‘IE— ns
Dutput alid Celay I‘IE— ns
Offset ID— ns

Inputs are azzigned, outputs are decoded then
checked. A delay between inputs and outputs avoids
assignment/checking conflicts.

Check Outputs IED nz After Inputs are Assigned
Agzign Inputs IED nz After Outputs are Checked

—[Global Signal

[~ PRLD(CPLD] | GSA(FPGA)

High far [nitial: |1 i} ns

Initial Length of Test Bench IZ‘DEIEI ng

Time Scale: | nz -

I~ &dd Asyrchronous Signal Support

Mare Infa |

cpack [ Erisn |

LCancel |

Click on FINISH
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A default set of waveforms for the inputs are created. IMPORTANT: You need to select
'""Behavioral Simulation' in the Sources For section on the left to be able to run the
simulations. Click on the blue parts of the input lines to toggle the level to set up an
appropriate set of input combinations. Then click File-Save all. Next you need to select
the ""Processes'' section under '"Processes' tab on the left.

[ES xilinx - ISE - C:\Documents and Settings\Kahraman\Desktop',encoder',encoder.ise - [encoder_waveform.thw]

BB Fis Edit Wisw Froject Source Process TestBench Simulation Window Help =& %
IDPHF LD ER P BERAA AR LWL R B[]0 oo m[52 =
[EED= -SRI A - s o |
=
- - = End Time:
ST Behaviocl Sinulaion B 50ns  250ns 450ns 650ns 850ns 1050ns 1250ns 1450ns 1650ns 1850ns
ercoder 2000 ns
& P b b bv b bbb b
- £ #e3s200-41255 anio 5 1
- [ encoder_wavefoim [encader_wavefam.ibw) ani I I s B R R B
[l UUT - encoder - Behavioral (encader.vhd -
aniz [l E R BB R
aniz 0
4] I2[f = @ana 0 0
o Seurces | oy Snapshels | [T Librares | AMar 0
5 AMam 0
Frocesses |
O Add Esisting Sourcs
[ Create New Source
[E]  Wiew Generated Test Bench s HOL
] Add Test Bench To Project
2% ModsiSim Simulstor
M Generats Expectsd Simulation Results
M Simulale Behavioral Model
4 LAR} LK} L’_I
2f Processes I'Il;H.e.archy-encnde.,wavefc« »
[f encoder | B ercocis_wavelor |

2 started : "Creating Thw file". |

Compiling vhdl file "C:/Documents and Settings/Kahraman/Desktop/encoder/encoder.vhd” in Library work.
Entity <encoder> compiled.
Entity <encoder> (Architecture <behaviorals) compiled.

J | o

[g] Console | @ Erors | g\ Warnings | [gg Findin Files |

Go back to the Project Navigator. You can either use ModelSim or ISE simulators as
described in the following sections. The ISE simulator is probably the easiest to use for
quick checks on your designs. Modelsim is far more powerful and flexible and we will
use this when we work with test benches.

a) MODELSIM Simulator

Double-click on the Simulate Behavioral VHDL Model process to launch the ModelSim
Simulator — ModelSim starts and displays many windows!

Go to the Waveform Viewer window and zoom back out to see the results of your
simulation:
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lﬁfwave - default = Il

File Edit Yiew Insert Format Tools Window

[DzRs it R S| ooaE || Ay | [ now Qa el | 4

| # (EAT o EIEIE B o
~ i IEI @1 | ]

(K H I (i M [V R i N A R i [V R 1] (]

[ 0 ps to 1196097 ps [ Mow: 2 us Delta: 0

£

b) ISE Simulator

Double-click on the Generate Expected Simulation Results process to launch the ISE
Simulator.

Click Yes

E Test Bench Waveform Editor E

\c:) Only one instance of encoder_waveform,tbw can be active at once, Would vou like to dose the current encoder_waveform.tbw and open a new one?
H

] | Cancel |

Click Yes

E Expected Results

\ql) Replace oukputs with expected values? Selecting Mo adds the expected values as signals ko the display For comparison,
-

Mo | Cancel |

And you get the outputs as shown in the following window.
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Documents and Settings'Kahramai esktop'.encoder' encodel - [encoder_waveform.tbw*]
File Edit Yiew Project Source Process TestBench Simulstion Window Help _|ﬁ'|5|

I EIPEIEE IR E P P C I Y GE =
2B 0E[P[t & e 22X H@ o 5= HZ i <

=
= - = End Time:
Sauross for: | Behaviorsl Simulation El 2000 ns S0ns 250ns 450ns 650ns B50ns 1050ns 1250ns 1450ns 1B50ns 1850 ns
] encoder e T O T 1T 0 o
- €7 #e3s200-40t256 anio i | =
= ncoder_wavefom [encoder_waveform. ] 1 1
25 UUT - encoder - Behavioral [encoder.vhd] B.Il |
iz il
aniz o B BEBENEN]
| 12 1|| = @anm 0 0 12 z B 0
E3 Sources | {51 Shapshots I [y Libraries I I al1) il
= M ao 0

Hierarchy of encoder_waveform:
e encader

B

4 L3
I I-J 1| L3 <II
BssES = Hierarchy - encoder_waveform I 4 | 3
encoder | BB encoder_wavefar. I

x| Process "Generate Expected Simulation Results" completed successfully :J
Compiling vhdl file "C:/Documents and Settings/Hahrawan/Desktop/encoder/encoder.vhd” in Library work.
Entity <encoder> compiled.

Entity <encoder> [Architecture <behavioral>) compiled.

=
4] | o

El Console | eEHDIS I A Warnings I 1pg Find in Files I
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Alternative Verilog Design

NOTE: As you would expect, an equivalent Verilog Design will result in exactly the
same logic being produced and the same simulation results.

Start Project Navigator. Select File => New Project
Enter name and location, select device.
Select New Source. Select Verilog Module and provide name:

rewsoze £

[2] Schematic

[Z] State Diagram

Test Bench Wavefom s
[2] User Document -

Verilog Module encodsi

[ Verilog Test Fisture

) WHDL Library Location

[#) WHDL Module W_‘
[F] WHOL Package

[ WHDL Test Bench

¥ 4dd to project

Bk [ News | Cancel | Help |

A Verilog skeleton is produced, add behavioral statements:

=1olx

xilinx - Project Navigator - C:\verilog'encoder_ver\encoder_ver.npl
Eile Edit Y¥ew Project Source Process Window Help

PELECIEEETNE RIS B IERIL] A% n|Q |
2l

B encoder_ver 155 odule encoder (10,11, 12,43, a) ; -1

1€ 5era0644-1 Opcdd
[=-[v] encoder [encader. v
B -- encoder_wavefarm [encoder_wavetorm. it

4] | ¥
B hindule Wiew l W Snapshot View I @ Library View I
x|
Processes for Source: "encoder’! I;|
[  AddExisting Source
B  Create New Source
= @ Design Entry Utiities
¥)  Create Schematic Symbol

= n Launch ModelSim Simulator
“ Wiew Command Line Log File

e - Wiew Verilog Instantiation Template
E--&#  User Constraints

— Create Timing Constraints

e i) Agsign Package Pins

{4 Edit Constrairts (Test) -
l : T | ﬂJ

B Process View I

encoder.y

input i0;
input il
input iZ;
input i3:
output [1:0] a:

teer [1:03 &5

always B(i0, i1, i2,i3)
if (i3 == 1'b1)
a <= 2!
else if (i2
a <= 2!
else if (il
a <= 2'b01;
else
a <= 2'b00;

| [Empty Log)

f‘ _>l_I
4[4k [#1] Console £ Findin Files A Wamings_h_Erors

For Help, press FL L1 ol 1 =

The rest of the steps are equivalent to the VHDL example.



